summaryrefslogtreecommitdiffstats
path: root/kopete/plugins/latex/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitbcb704366cb5e333a626c18c308c7e0448a8e69f (patch)
treef0d6ab7d78ecdd9207cf46536376b44b91a1ca71 /kopete/plugins/latex/Makefile.am
downloadtdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.tar.gz
tdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdenetwork@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kopete/plugins/latex/Makefile.am')
-rw-r--r--kopete/plugins/latex/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/kopete/plugins/latex/Makefile.am b/kopete/plugins/latex/Makefile.am
new file mode 100644
index 00000000..924da747
--- /dev/null
+++ b/kopete/plugins/latex/Makefile.am
@@ -0,0 +1,27 @@
+METASOURCES = AUTO
+
+SUBDIRS = icons
+
+AM_CPPFLAGS = $(KOPETE_INCLUDES) $(all_includes)
+
+kde_module_LTLIBRARIES = kopete_latex.la kcm_kopete_latex.la
+
+kopete_latex_la_SOURCES = latexplugin.cpp latexconfig.kcfgc latexguiclient.cpp
+kopete_latex_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN) $(all_libraries)
+kopete_latex_la_LIBADD = ../../libkopete/libkopete.la
+
+kcm_kopete_latex_la_SOURCES = latexprefsbase.ui latexpreferences.cpp latexconfig.kcfgc
+kcm_kopete_latex_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN) $(all_libraries)
+kcm_kopete_latex_la_LIBADD = $(LIB_KOPETECOMPAT) $(LIB_KUTILS)
+
+service_DATA = kopete_latex.desktop
+servicedir = $(kde_servicesdir)
+
+kcm_DATA = kopete_latex_config.desktop
+kcmdir = $(kde_servicesdir)/kconfiguredialog
+
+bin_SCRIPTS = kopete_latexconvert.sh
+kde_kcfg_DATA = latexconfig.kcfg
+
+mydatadir = $(kde_datadir)/kopete_latex
+mydata_DATA = latexchatui.rc \ No newline at end of file