summaryrefslogtreecommitdiffstats
path: root/kopete/protocols/groupwise/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-01-06 19:41:48 +0100
committerSlávek Banko <slavek.banko@axis.cz>2020-02-02 04:40:27 +0100
commit1037d386233764a3fd46c8e18699c874520d6d9e (patch)
treeefbf197f81d814e062bb40aec490056c46f5a5ec /kopete/protocols/groupwise/CMakeLists.txt
parent115400db72f2a55daa516ff56bd570902b42029a (diff)
downloadtdenetwork-1037d386233764a3fd46c8e18699c874520d6d9e.tar.gz
tdenetwork-1037d386233764a3fd46c8e18699c874520d6d9e.zip
kopete: Added ability to build with shared tqca library.
QCA files renamed to TQCA to match tqca library. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kopete/protocols/groupwise/CMakeLists.txt')
-rw-r--r--kopete/protocols/groupwise/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/kopete/protocols/groupwise/CMakeLists.txt b/kopete/protocols/groupwise/CMakeLists.txt
index c6df3323..637ae143 100644
--- a/kopete/protocols/groupwise/CMakeLists.txt
+++ b/kopete/protocols/groupwise/CMakeLists.txt
@@ -9,6 +9,11 @@
#
#################################################
+if( NOT TQCA_FOUND )
+ set( TQCA_INCLUDE_DIR ${CMAKE_CURRENT_SOURCE_DIR}/libgroupwise/qca/src )
+ set( TQCA_LIBRARIES "groupwise_tqca-static" )
+endif( )
+
add_subdirectory( icons )
add_subdirectory( libgroupwise )
add_subdirectory( ui )
@@ -18,12 +23,12 @@ include_directories(
${CMAKE_CURRENT_BINARY_DIR}/ui
${CMAKE_CURRENT_SOURCE_DIR}/libgroupwise
${CMAKE_CURRENT_SOURCE_DIR}/libgroupwise/tasks
- ${CMAKE_CURRENT_SOURCE_DIR}/libgroupwise/qca/src
${CMAKE_CURRENT_SOURCE_DIR}/ui
${CMAKE_SOURCE_DIR}/kopete/libkopete
${CMAKE_SOURCE_DIR}/kopete/libkopete/ui
${TDE_INCLUDE_DIR}
${TQT_INCLUDE_DIRS}
+ ${TQCA_INCLUDE_DIR}
)
link_directories(
@@ -45,6 +50,6 @@ tde_add_kpart( kopete_groupwise AUTOMOC
gwconnector.cpp gwmessagemanager.cpp gwcontactlist.cpp
LINK
kopetegroupwiseui-static groupwise-static groupwise_tasks-static
- groupwise_qca-static kopete-shared
+ ${TQCA_LIBRARIES} kopete-shared
DESTINATION ${PLUGIN_INSTALL_DIR}
)