summaryrefslogtreecommitdiffstats
path: root/kopete/protocols/groupwise/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitbcb704366cb5e333a626c18c308c7e0448a8e69f (patch)
treef0d6ab7d78ecdd9207cf46536376b44b91a1ca71 /kopete/protocols/groupwise/Makefile.am
downloadtdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.tar.gz
tdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdenetwork@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kopete/protocols/groupwise/Makefile.am')
-rw-r--r--kopete/protocols/groupwise/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/kopete/protocols/groupwise/Makefile.am b/kopete/protocols/groupwise/Makefile.am
new file mode 100644
index 00000000..0c8a38fc
--- /dev/null
+++ b/kopete/protocols/groupwise/Makefile.am
@@ -0,0 +1,26 @@
+
+
+SUBDIRS = icons libgroupwise ui
+
+AM_CPPFLAGS = $(KOPETE_INCLUDES) $(all_includes)
+
+METASOURCES = AUTO
+
+noinst_HEADERS = gwprotocol.h gwcontact.h gwaccount.h gwbytestream.h \
+ gwconnector.h gwmessagemanager.h gwcontactlist.h
+kde_module_LTLIBRARIES = kopete_groupwise.la
+kopete_groupwise_la_SOURCES = gwprotocol.cpp gwcontact.cpp gwaccount.cpp \
+ gwbytestream.cpp gwconnector.cpp gwmessagemanager.cpp gwcontactlist.cpp
+kopete_groupwise_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN) \
+ $(all_libraries)
+kopete_groupwise_la_LIBADD = ui/libkopetegroupwiseui.la \
+ libgroupwise/libgroupwise.la ../../libkopete/libkopete.la $(LIB_KIO)
+
+service_DATA = kopete_groupwise.desktop
+servicedir = $(kde_servicesdir)
+INCLUDES = -I$(top_srcdir)/kopete/protocols/groupwise/libgroupwise/tasks \
+ -I$(top_srcdir)/kopete/protocols/groupwise/libgroupwise/qca/src -I$(top_srcdir)/kopete/protocols/groupwise/libgroupwise \
+ -I$(top_srcdir)/kopete/protocols/groupwise/ui -I$(top_builddir)/kopete/protocols/groupwise/ui
+
+mydatadir = $(kde_datadir)/kopete_groupwise
+mydata_DATA = gwchatui.rc