summaryrefslogtreecommitdiffstats
path: root/kopete/protocols/msn/webcam/libmimic/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-12-11 01:41:26 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-12-11 02:23:35 +0100
commit73f00336178a9f312bac2992649120d462e0ac2d (patch)
tree8672519cb50cb0e642af0817188ad28f810338ee /kopete/protocols/msn/webcam/libmimic/CMakeLists.txt
parent914254104c50dec222fb31ce7a25a21870e90f16 (diff)
downloadtdenetwork-73f00336178a9f312bac2992649120d462e0ac2d.tar.gz
tdenetwork-73f00336178a9f312bac2992649120d462e0ac2d.zip
kopete: Restore the MSN protocol because a replacement MSN server was created.
This reverts commits 0486034738 - 2d5f9c55da and f6fd4ab6c0. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kopete/protocols/msn/webcam/libmimic/CMakeLists.txt')
-rw-r--r--kopete/protocols/msn/webcam/libmimic/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/kopete/protocols/msn/webcam/libmimic/CMakeLists.txt b/kopete/protocols/msn/webcam/libmimic/CMakeLists.txt
new file mode 100644
index 00000000..5a340661
--- /dev/null
+++ b/kopete/protocols/msn/webcam/libmimic/CMakeLists.txt
@@ -0,0 +1,24 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${GLIB2_INCLUDE_DIRS}
+)
+
+
+##### mimic (static) ############################
+
+tde_add_library( mimic STATIC_PIC
+ SOURCES
+ mimic.c encode.c decode.c bitstring.c vlc_common.c vlc_encode.c
+ vlc_decode.c fdct_quant.c idct_dequant.c colorspace.c deblock.c
+ LINK ${GLIB2_LIBRARIES}
+)