summaryrefslogtreecommitdiffstats
path: root/kpf/src/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitbcb704366cb5e333a626c18c308c7e0448a8e69f (patch)
treef0d6ab7d78ecdd9207cf46536376b44b91a1ca71 /kpf/src/Makefile.am
downloadtdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.tar.gz
tdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdenetwork@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kpf/src/Makefile.am')
-rw-r--r--kpf/src/Makefile.am89
1 files changed, 89 insertions, 0 deletions
diff --git a/kpf/src/Makefile.am b/kpf/src/Makefile.am
new file mode 100644
index 00000000..5d419f0f
--- /dev/null
+++ b/kpf/src/Makefile.am
@@ -0,0 +1,89 @@
+INCLUDES = $(all_includes)
+
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = kpf_panelapplet.la kpfpropertiesdialog.la
+
+kpf_panelapplet_la_SOURCES = \
+ Utils.cpp \
+ DirectoryLister.cpp \
+ ByteRange.cpp \
+ DirSelectWidget.cpp \
+ PortValidator.cpp \
+ Request.cpp \
+ Response.cpp \
+ Resource.cpp \
+ RootValidator.cpp \
+ Server.cpp \
+ ServerPrivate.cpp \
+ ServerSocket.cpp \
+ WebServer.cpp \
+ WebServer.skel \
+ WebServer.stub \
+ WebServerSocket.cpp \
+ WebServerManager.cpp \
+ WebServerManager.skel \
+ SingleServerConfigDialog.cpp \
+ System.cpp \
+ ConfigDialogPage.cpp \
+ ErrorMessageConfigDialog.cpp \
+ ActiveMonitor.cpp \
+ ActiveMonitorItem.cpp \
+ ActiveMonitorWindow.cpp \
+ BandwidthGraph.cpp \
+ ServerWizard.cpp \
+ AppletItem.cpp \
+ Applet.cpp \
+ Defaults.cpp \
+ Help.cpp
+
+kpf_panelapplet_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module
+
+kpf_panelapplet_la_LIBADD = $(LIB_KIO) -lkdnssd
+
+kpfpropertiesdialog_la_SOURCES = \
+ PropertiesDialogPlugin.cpp \
+ StartingKPFDialog.cpp \
+ WebServer.stub \
+ WebServerManager.stub \
+ Defaults.cpp \
+ Help.cpp
+
+kpfpropertiesdialog_la_LIBADD = $(LIB_KIO) -lkdnssd
+
+kpfpropertiesdialog_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module
+
+noinst_HEADERS = \
+ Utils.h \
+ Defaults.h \
+ DirectoryLister.h \
+ DirSelectWidget.h \
+ ByteRange.h \
+ PortValidator.h \
+ Request.h \
+ Response.h \
+ Resource.h \
+ RootValidator.h \
+ Server.h \
+ ServerPrivate.h \
+ ServerSocket.h \
+ WebServer.h \
+ WebServerSocket.h \
+ WebServerManager.h \
+ SingleServerConfigDialog.h \
+ ConfigDialogPage.h \
+ PropertiesDialogPlugin.h \
+ StartingKPFDialog.h \
+ ErrorMessageConfigDialog.h \
+ ActiveMonitor.h \
+ ActiveMonitorItem.h \
+ ActiveMonitorWindow.h \
+ BandwidthGraph.h \
+ ServerWizard.h \
+ AppletItem.h \
+ Applet.h \
+ Help.h
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kpf.pot
+