summaryrefslogtreecommitdiffstats
path: root/wifi/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitbcb704366cb5e333a626c18c308c7e0448a8e69f (patch)
treef0d6ab7d78ecdd9207cf46536376b44b91a1ca71 /wifi/Makefile.am
downloadtdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.tar.gz
tdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdenetwork@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'wifi/Makefile.am')
-rw-r--r--wifi/Makefile.am56
1 files changed, 56 insertions, 0 deletions
diff --git a/wifi/Makefile.am b/wifi/Makefile.am
new file mode 100644
index 00000000..22c1a4c2
--- /dev/null
+++ b/wifi/Makefile.am
@@ -0,0 +1,56 @@
+# Yow, Emacs, this is a -*- makefile -*-
+
+xdg_apps_DATA = kwifimanager.desktop
+
+EXTRA_DIST = $(xdg_apps_DATA)
+INCLUDES = $(all_includes)
+
+SUBDIRS = kcmwifi kwireless pixmaps locations
+
+bin_PROGRAMS = kwifimanager
+
+kwifimanager_SOURCES = interface_wireless.cpp \
+ interface_wireless_wirelessextensions.cpp \
+ interface_dcop.skel \
+ networkscanning.cpp \
+ kwifimanager.cpp \
+ locator.cpp \
+ main.cpp \
+ picture.cpp \
+ speed.cpp \
+ statistics.cpp \
+ status.cpp \
+ strength.cpp \
+ asusled.cpp
+
+kwifimanager_LDFLAGS = $(all_libraries)
+
+if include_ARTS
+ARTS_LIBS = -lartsflow -lmcop
+endif
+
+kwifimanager_LDADD = $(ARTS_LIBS) -liw $(LIB_KDEUI)
+
+noinst_HEADERS = interface_wireless.h \
+ interface_wireless_wirelessextensions.h \
+ interface_dcop.h \
+ networkscanning.h \
+ kwifimanager.h \
+ locator.h \
+ picture.h \
+ speed.h \
+ statistics.h \
+ status.h \
+ strength.h \
+ asusled.h
+
+METASOURCES = AUTO
+
+KDE_ICON = AUTO
+
+appdir=$(kde_datadir)/kwifimanager
+app_DATA = kwifimanagerui.rc
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kwifimanager.pot
+