summaryrefslogtreecommitdiffstats
path: root/tdefile-plugins/torrent/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdefile-plugins/torrent/Makefile.am')
-rw-r--r--tdefile-plugins/torrent/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/tdefile-plugins/torrent/Makefile.am b/tdefile-plugins/torrent/Makefile.am
new file mode 100644
index 00000000..299dbe45
--- /dev/null
+++ b/tdefile-plugins/torrent/Makefile.am
@@ -0,0 +1,22 @@
+## Makefile.am for folder file meta info plugin
+
+INCLUDES = $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = tdefile_torrent.h bbase.h bdict.h bytetape.h \
+ bstring.h bint.h blist.h
+
+kde_module_LTLIBRARIES = tdefile_torrent.la
+
+tdefile_torrent_la_SOURCES = bytetape.cpp bint.cpp bstring.cpp blist.cpp bdict.cpp tdefile_torrent.cpp
+tdefile_torrent_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -ltdetexteditor
+tdefile_torrent_la_LIBADD = $(LIB_KIO)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+services_DATA = tdefile_torrent.desktop
+servicesdir = $(kde_servicesdir)
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/tdefile_torrent.pot