summaryrefslogtreecommitdiffstats
path: root/kpacman/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kpacman/Makefile.am')
-rw-r--r--kpacman/Makefile.am74
1 files changed, 0 insertions, 74 deletions
diff --git a/kpacman/Makefile.am b/kpacman/Makefile.am
deleted file mode 100644
index 76ab862..0000000
--- a/kpacman/Makefile.am
+++ /dev/null
@@ -1,74 +0,0 @@
-####### tdevelop will overwrite this part!!! (begin)##########
-bin_PROGRAMS = kpacman
-
-## INCLUDES were found outside tdevelop specific part
-
-kpacman_SOURCES = kpacmanview.cpp referee.cpp status.cpp painter.cpp score.cpp pacman.cpp monster.cpp keys.cpp fruit.cpp energizer.cpp board.cpp bitfont.cpp kpacman.cpp main.cpp
-kpacman_LDADD = -ltdegames $(LIB_TDEUI) $(LIB_TDECORE) $(LIB_TQT) $(LIBSOCKET)
-
-
-EXTRA_DIST = main.cpp kpacman.cpp kpacman.h kpacman.desktop lo32-app-kpacman.png lo16-app-kpacman.png bitfont.cpp bitfont.h colors.h bitmaps.h board.cpp board.h energizer.cpp energizer.h fruit.cpp fruit.h keys.cpp keys.h monster.cpp monster.h pacman.cpp pacman.h score.cpp score.h painter.cpp painter.h status.cpp status.h referee.cpp referee.h kpacmanrc kpacmanview.h kpacmanview.cpp kpacmanui.rc hi16-app-kpacman.png hi32-app-kpacman.png
-
-install-data-local:
- $(mkinstalldirs) $(kde_appsdir)/Games/
- $(INSTALL_DATA) $(srcdir)/kpacman.desktop $(kde_appsdir)/Games/kpacman.desktop
- $(mkinstalldirs) $(kde_icondir)/locolor/32x32/apps/
- $(INSTALL_DATA) $(srcdir)/lo32-app-kpacman.png $(kde_icondir)/locolor/32x32/apps/kpacman.png
- $(mkinstalldirs) $(kde_icondir)/locolor/16x16/apps/
- $(INSTALL_DATA) $(srcdir)/lo16-app-kpacman.png $(kde_icondir)/locolor/16x16/apps/kpacman.png
- $(mkinstalldirs) $(kde_confdir)/
- $(INSTALL_DATA) $(srcdir)/kpacmanrc $(kde_confdir)/kpacmanrc
- $(mkinstalldirs) $(kde_icondir)/hicolor/16x16/apps/
- $(INSTALL_DATA) $(srcdir)/hi16-app-kpacman.png $(kde_icondir)/hicolor/16x16/apps/kpacman.png
- $(mkinstalldirs) $(kde_icondir)/hicolor/32x32/apps/
- $(INSTALL_DATA) $(srcdir)/hi32-app-kpacman.png $(kde_icondir)/hicolor/32x32/apps/kpacman.png
-
-uninstall-local:
- -rm -f $(kde_appsdir)/Games/kpacman.desktop
- -rm -f $(kde_icondir)/locolor/32x32/apps/kpacman.png
- -rm -f $(kde_icondir)/locolor/16x16/apps/kpacman.png
- -rm -f $(kde_confdir)/kpacmanrc
- -rm -f $(kde_icondir)/hicolor/16x16/apps/kpacman.png
- -rm -f $(kde_icondir)/hicolor/32x32/apps/kpacman.png
-
-####### tdevelop will overwrite this part!!! (end)############
-# this 10 paths are KDE specific. Use them:
-# kde_htmldir Where your docs should go to. (contains lang subdirs)
-# kde_appsdir Where your application file (.kdelnk) should go to.
-# kde_icondir Where your icon should go to.
-# kde_minidir Where your mini icon should go to.
-# kde_datadir Where you install application data. (Use a subdir)
-# kde_locale Where translation files should go to.(contains lang subdirs)
-# kde_cgidir Where cgi-bin executables should go to.
-# kde_confdir Where config files should go to.
-# kde_mimedir Where mimetypes should go to.
-# kde_toolbardir Where general toolbar icons should go to.
-# kde_wallpaperdir Where general wallpapers should go to.
-
-# set the include path for X, qt and KDE
-INCLUDES= $(all_includes)
-
-METASOURCES = AUTO
-
-# the library search path.
-kpacman_LDFLAGS = $(all_libraries) $(KDE_RPATH)
-
-# Uncomment the following two lines if you add a ui.rc file for your application to make use of
-# KDE
-rcdir = $(kde_datadir)/kpacman
-rc_DATA = kpacmanui.rc
-
-#WARNING: if you use a ui.rc file above, use:
-
-# messages: rc.cpp
-
-# instead of
-
-# messages:
-
-messages: rc.cpp
- LIST=`find . -name \*.h -o -name \*.hh -o -name \*.H -o -name \*.hxx -o -name \*.hpp -o -name \*.cpp -o -name \*.cc -o -name \*.cxx -o -name \*.ecpp -o -name \*.C`; \
- if test -n "$$LIST"; then \
- $(XGETTEXT) $$LIST -o $(podir)/kpacman.pot; \
- fi
-