summaryrefslogtreecommitdiffstats
path: root/akregator/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
commit0d3043b6308af148da06ac14c53defc4b1e7e138 (patch)
tree2e9364cb143e70ee062e443275b852b8e2061888 /akregator/src/CMakeLists.txt
parent7c7363c3ca7fb9633d93cefde3cd54b144eee633 (diff)
downloadtdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.tar.gz
tdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'akregator/src/CMakeLists.txt')
-rw-r--r--akregator/src/CMakeLists.txt37
1 files changed, 25 insertions, 12 deletions
diff --git a/akregator/src/CMakeLists.txt b/akregator/src/CMakeLists.txt
index b1bb367d0..557d2acff 100644
--- a/akregator/src/CMakeLists.txt
+++ b/akregator/src/CMakeLists.txt
@@ -46,26 +46,39 @@ install( FILES
tde_install_icons( )
-install( FILES
- akregator.desktop
- DESTINATION ${XDG_APPS_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE akregator.desktop
+ PO_DIR akregator-desktops
+)
install( FILES
akregator.kcfg
DESTINATION ${KCFG_INSTALL_DIR} )
-install( FILES
- akregator_part.desktop feed.protocol
- DESTINATION ${SERVICES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE akregator_part.desktop feed.protocol
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR akregator-desktops
+)
-install( FILES
- akregator_plugin.desktop
- DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE akregator_plugin.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR akregator-desktops
+)
-install( FILES
- akregator_shell.rc articleviewer.rc eventsrc
+tde_create_translated_desktop(
+ SOURCE eventsrc
+ DESTINATION ${DATA_INSTALL_DIR}/akregator
+ PO_DIR akregator-eventsrc
+)
+
+install(
+ FILES
+ akregator_shell.rc articleviewer.rc
pageviewer.rc akregator_part.rc
- DESTINATION ${DATA_INSTALL_DIR}/akregator )
+ DESTINATION ${DATA_INSTALL_DIR}/akregator
+)
##### akregatorprivate (shared) #################