summaryrefslogtreecommitdiffstats
path: root/karm/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
commit0d3043b6308af148da06ac14c53defc4b1e7e138 (patch)
tree2e9364cb143e70ee062e443275b852b8e2061888 /karm/CMakeLists.txt
parent7c7363c3ca7fb9633d93cefde3cd54b144eee633 (diff)
downloadtdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.tar.gz
tdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'karm/CMakeLists.txt')
-rw-r--r--karm/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/karm/CMakeLists.txt b/karm/CMakeLists.txt
index a8cdc5a1b..48286f441 100644
--- a/karm/CMakeLists.txt
+++ b/karm/CMakeLists.txt
@@ -38,7 +38,13 @@ link_directories(
##### other data ################################
tde_install_icons( karm )
-install( FILES karm_part.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+
+tde_create_translated_desktop(
+ SOURCE karm_part.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR karm-desktops
+)
+
install( FILES uninstall.desktop RENAME karm.desktop DESTINATION ${APPS_INSTALL_DIR}/Utilities )
install( FILES karmui.rc DESTINATION ${DATA_INSTALL_DIR}/karm )
install( FILES karmui.rc DESTINATION ${DATA_INSTALL_DIR}/karmpart )