summaryrefslogtreecommitdiffstats
path: root/knotes/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
commit0d3043b6308af148da06ac14c53defc4b1e7e138 (patch)
tree2e9364cb143e70ee062e443275b852b8e2061888 /knotes/CMakeLists.txt
parent7c7363c3ca7fb9633d93cefde3cd54b144eee633 (diff)
downloadtdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.tar.gz
tdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'knotes/CMakeLists.txt')
-rw-r--r--knotes/CMakeLists.txt20
1 files changed, 17 insertions, 3 deletions
diff --git a/knotes/CMakeLists.txt b/knotes/CMakeLists.txt
index 198d124e8..92708c36a 100644
--- a/knotes/CMakeLists.txt
+++ b/knotes/CMakeLists.txt
@@ -39,11 +39,25 @@ install( FILES KNotesIface.h KNotesAppIface.h DESTINATION ${INCLUDE_INSTALL_DIR}
##### other data ################################
-install( FILES knotes.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE knotes.desktop
+ PO_DIR knotes-desktops
+)
+
install( FILES knoteconfig.kcfg knotesglobalconfig.kcfg DESTINATION ${KCFG_INSTALL_DIR} )
install( FILES knotesappui.rc knotesui.rc DESTINATION ${DATA_INSTALL_DIR}/knotes )
-install( FILES local.desktop DESTINATION ${SERVICES_INSTALL_DIR}/tderesources/knotes )
-install( FILES knotes_manager.desktop DESTINATION ${SERVICES_INSTALL_DIR}/tderesources )
+
+tde_create_translated_desktop(
+ SOURCE local.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/tderesources/knotes
+ PO_DIR knotes-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE knotes_manager.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/tderesources
+ PO_DIR knotes-desktops
+)
##### knotes (executable) #######################