summaryrefslogtreecommitdiffstats
path: root/kode/kwsdl/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit460c52653ab0dcca6f19a4f492ed2c5e4e963ab0 (patch)
tree67208f7c145782a7e90b123b982ca78d88cc2c87 /kode/kwsdl/Makefile.am
downloadtdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.tar.gz
tdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kode/kwsdl/Makefile.am')
-rw-r--r--kode/kwsdl/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/kode/kwsdl/Makefile.am b/kode/kwsdl/Makefile.am
new file mode 100644
index 000000000..bc7d0d1f3
--- /dev/null
+++ b/kode/kwsdl/Makefile.am
@@ -0,0 +1,19 @@
+SUBDIRS = schema . wscl tests kung
+
+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/libkdepim $(all_includes)
+
+lib_LTLIBRARIES = libwsdl.la
+
+libwsdl_la_SOURCES = binding.cpp message.cpp parser.cpp port.cpp service.cpp \
+ typemapper.cpp wsdl.cpp
+libwsdl_la_LDFLAGS = $(all_libraries) -version-info 1:0:0 -no-undefined
+libwsdl_la_LIBADD = -lkdecore schema/libschema.la
+
+bin_PROGRAMS = kwsdl_compiler
+
+kwsdl_compiler_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+kwsdl_compiler_LDADD = ../libkode.la libwsdl.la
+kwsdl_compiler_SOURCES = compiler.cpp converter.cpp creator.cpp main.cpp \
+ namemapper.cpp
+
+METASOURCES = AUTO