summaryrefslogtreecommitdiffstats
path: root/kontact/plugins/kaddressbook/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit460c52653ab0dcca6f19a4f492ed2c5e4e963ab0 (patch)
tree67208f7c145782a7e90b123b982ca78d88cc2c87 /kontact/plugins/kaddressbook/Makefile.am
downloadtdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.tar.gz
tdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kontact/plugins/kaddressbook/Makefile.am')
-rw-r--r--kontact/plugins/kaddressbook/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/kontact/plugins/kaddressbook/Makefile.am b/kontact/plugins/kaddressbook/Makefile.am
new file mode 100644
index 000000000..a769f29d8
--- /dev/null
+++ b/kontact/plugins/kaddressbook/Makefile.am
@@ -0,0 +1,18 @@
+INCLUDES = -I$(top_srcdir)/kontact/interfaces -I$(top_srcdir) $(all_includes)
+
+kde_module_LTLIBRARIES = libkontact_kaddressbookplugin.la
+libkontact_kaddressbookplugin_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -lkabc
+libkontact_kaddressbookplugin_la_LIBADD = $(top_builddir)/kontact/interfaces/libkpinterfaces.la $(top_builddir)/libkdepim/libkdepim.la
+
+libkontact_kaddressbookplugin_la_SOURCES = kaddressbook_plugin.cpp \
+ kaddressbookiface.stub \
+ kmailIface.stub
+
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)/kontact
+service_DATA = kaddressbookplugin.desktop
+
+kaddressbookiface_DIR = $(top_srcdir)/kaddressbook
+kmailIface_DIR = $(top_srcdir)/kmail
+kmailIface_DCOPIDLNG = true