summaryrefslogtreecommitdiffstats
path: root/kresources/groupwise/soap/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit460c52653ab0dcca6f19a4f492ed2c5e4e963ab0 (patch)
tree67208f7c145782a7e90b123b982ca78d88cc2c87 /kresources/groupwise/soap/Makefile.am
downloadtdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.tar.gz
tdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kresources/groupwise/soap/Makefile.am')
-rw-r--r--kresources/groupwise/soap/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/kresources/groupwise/soap/Makefile.am b/kresources/groupwise/soap/Makefile.am
new file mode 100644
index 000000000..d0793429c
--- /dev/null
+++ b/kresources/groupwise/soap/Makefile.am
@@ -0,0 +1,47 @@
+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/kresources/groupwise $(all_includes)
+
+#AM_CPPFLAGS = -DDEBUG
+KDE_CXXFLAGS = -Wno-non-virtual-dtor
+
+check_PROGRAMS = soapdebug
+
+soapdebug_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+soapdebug_LDADD = libgwsoap.la -lkdecore \
+ $(top_builddir)/libkcal/libkcal.la \
+ $(top_builddir)/libkdepim/libkdepim.la
+soapdebug_SOURCES = soapdebug.cpp
+
+lib_LTLIBRARIES = libgwsoap.la
+
+libgwsoap_la_SOURCES = contactconverter.cpp gwconverter.cpp incidenceconverter.cpp \
+ groupwiseserver.cpp gwjobs.cpp ksslsocket.cpp \
+ soapC.cpp soapClient.cpp stdsoap2.cpp
+libgwsoap_la_LDFLAGS = $(KDE_RPATH) $(all_libraries) -no-undefined
+libgwsoap_la_LIBADD = $(top_builddir)/libkcal/libkcal.la $(top_builddir)/libkdepim/libkdepim.la
+
+# the following rule does:
+# make a header file from the wsdl
+# remove ns1__ prefixes from generated functions
+# create the stubs from the header
+# rename any 'delete' method declarations
+# rename any 'delete' method invocations
+# rename any 'new' method decls
+# rename any 'new' method invocations
+
+# do not just set "srcdir=." here, it breaks when building with srcdir!=builddir
+# srcdir = .
+
+stubs: groupwise.wsdl
+ wsdl2h -e -o $(srcdir)/groupwise.h $(srcdir)/groupwise.wsdl -t $(srcdir)/typemap.dat
+ cd $(srcdir); ./fixup_groupwise.h.pl --inplace
+ soapcpp2 -d $(srcdir) -I$(srcdir) $(srcdir)/groupwise.h
+ sed -e 's,*delete\([^d]\),*_delete\1,' $(srcdir)/soapStub.h > $(srcdir)/soapStub.h_
+ mv $(srcdir)/soapStub.h_ $(srcdir)/soapStub.h
+ sed -e 's,->delete\([^d]\),->_delete\1,' $(srcdir)/soapC.cpp > $(srcdir)/soapC.cpp_
+ mv $(srcdir)/soapC.cpp_ $(srcdir)/soapC.cpp
+ sed -e 's,*new\([^d]\),*_new\1,' $(srcdir)/soapStub.h > $(srcdir)/soapStub.h_
+ mv $(srcdir)/soapStub.h_ $(srcdir)/soapStub.h
+ sed -e 's,->new\([^d]\),->_new\1,' $(srcdir)/soapC.cpp > $(srcdir)/soapC.cpp_
+ mv $(srcdir)/soapC.cpp_ $(srcdir)/soapC.cpp
+
+METASOURCES = AUTO