summaryrefslogtreecommitdiffstats
path: root/kresources/remote/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:50 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:50 -0600
commitb363d2579af0a11b77e698aed2e1021c2233b644 (patch)
treef4a47b87354b7a6a3b266c8121bd8ddaeb7accaa /kresources/remote/CMakeLists.txt
parent61bddfe3a7226b18c68a76124b727c736f431688 (diff)
downloadtdepim-b363d2579af0a11b77e698aed2e1021c2233b644.tar.gz
tdepim-b363d2579af0a11b77e698aed2e1021c2233b644.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'kresources/remote/CMakeLists.txt')
-rw-r--r--kresources/remote/CMakeLists.txt56
1 files changed, 0 insertions, 56 deletions
diff --git a/kresources/remote/CMakeLists.txt b/kresources/remote/CMakeLists.txt
deleted file mode 100644
index d1a4b57b1..000000000
--- a/kresources/remote/CMakeLists.txt
+++ /dev/null
@@ -1,56 +0,0 @@
-#################################################
-#
-# (C) 2010-2011 Serghei Amelian
-# serghei (DOT) amelian (AT) gmail.com
-#
-# Improvements and feedback are welcome
-#
-# This file is released under GPL >= 2
-#
-#################################################
-
-include_directories(
- ${CMAKE_CURRENT_BINARY_DIR}
- ${CMAKE_SOURCE_DIR}
- ${CMAKE_SOURCE_DIR}/libtdepim
- ${TDE_INCLUDE_DIR}
- ${TQT_INCLUDE_DIRS}
-)
-
-link_directories(
- ${TQT_LIBRARY_DIRS}
-)
-
-
-##### headers ###################################
-
-install( FILES
- resourceremoteconfig.h resourceremote.h
- DESTINATION ${INCLUDE_INSTALL_DIR}/libkcal )
-
-
-##### other data ################################
-
-install( FILES
- remote.desktop
- DESTINATION ${SERVICES_INSTALL_DIR}/kresources/kcal )
-
-
-##### kcal_remote (module) ######################
-
-tde_add_kpart( kcal_remote AUTOMOC
- SOURCES resourceremote_plugin.cpp
- LINK kcal_resourceremote-shared
- DESTINATION ${PLUGIN_INSTALL_DIR}
-)
-
-
-##### kcal_resourceremote (shared) ##############
-
-tde_add_library( kcal_resourceremote SHARED AUTOMOC
- SOURCES
- resourceremote.cpp resourceremoteconfig.cpp
- VERSION 1.0.0
- LINK tdepim-shared
- DESTINATION ${LIB_INSTALL_DIR}
-)