summaryrefslogtreecommitdiffstats
path: root/libkpimexchange/core/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit460c52653ab0dcca6f19a4f492ed2c5e4e963ab0 (patch)
tree67208f7c145782a7e90b123b982ca78d88cc2c87 /libkpimexchange/core/Makefile.am
downloadtdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.tar.gz
tdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'libkpimexchange/core/Makefile.am')
-rw-r--r--libkpimexchange/core/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/libkpimexchange/core/Makefile.am b/libkpimexchange/core/Makefile.am
new file mode 100644
index 000000000..cc19fd79c
--- /dev/null
+++ b/libkpimexchange/core/Makefile.am
@@ -0,0 +1,27 @@
+# $Id$
+
+SUBDIRS=
+
+METASOURCES = AUTO
+
+INCLUDES = -I$(top_srcdir)/korganizer/interfaces -I$(top_srcdir) \
+ -I$(top_srcdir)/libkcal/libical/src/libical -I$(top_srcdir)/libkcal/libical/src/libicalss \
+ -I$(top_builddir)/libkcal/libical/src/libical -I$(top_builddir)/libkcal/libical/src/libicalss \
+ $(all_includes)
+
+# -I$(top_builddir)/libkdepim/resources -I$(top_builddir)/libkdepim/resources/calendar
+
+noinst_LTLIBRARIES = libkpimexchangecore.la
+
+libkpimexchangecore_la_SOURCES = exchangeclient.cpp exchangeaccount.cpp \
+ exchangedownload.cpp exchangeupload.cpp exchangedelete.cpp \
+ utils.cpp exchangeprogress.cpp exchangemonitor.cpp
+
+#libkpimexchange_la_LDFLAGS = $(all_libraries) -no-undefined -version-info 1:0:0 -module
+#libkpimexchange_la_LIBADD = $(LIB_KIO) $(top_builddir)/libkcal/libkcal.la
+
+kdepimincludedir = $(includedir)/kdepim
+kdepiminclude_HEADERS = exchangeclient.h exchangeaccount.h
+
+noinst_HEADERS = exchangedownload.h exchangeupload.h exchangedelete.h exchangeprogress.h utils.h
+