summaryrefslogtreecommitdiffstats
path: root/tdeioslaves/opengroupware/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:05:15 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:05:15 -0600
commit64df902cf71a8ee258fb85f6be26248f399aa01f (patch)
treedba58f705042c22cea26b678d5b0e4e9a34bf202 /tdeioslaves/opengroupware/Makefile.am
parentde53c98cab07e9c4b0f5e25dab82830fb6fc67ec (diff)
downloadtdepim-64df902cf71a8ee258fb85f6be26248f399aa01f.tar.gz
tdepim-64df902cf71a8ee258fb85f6be26248f399aa01f.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeioslaves/opengroupware/Makefile.am')
-rw-r--r--tdeioslaves/opengroupware/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/tdeioslaves/opengroupware/Makefile.am b/tdeioslaves/opengroupware/Makefile.am
new file mode 100644
index 000000000..007d74c36
--- /dev/null
+++ b/tdeioslaves/opengroupware/Makefile.am
@@ -0,0 +1,17 @@
+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/tderesources/opengroupware/soap \
+ $(all_includes)
+
+noinst_HEADERS = opengroupware.h
+
+METASOURCES = AUTO
+
+kdelnkdir = $(kde_servicesdir)
+kdelnk_DATA = opengroupware.protocol opengroupwares.protocol
+
+kde_module_LTLIBRARIES = kio_opengroupware.la
+
+kio_opengroupware_la_SOURCES = opengroupware.cpp webdavhandler.cpp
+kio_opengroupware_la_LIBADD = $(top_builddir)/libkcal/libkcal.la \
+ $(top_builddir)/libtdepim/libtdepim.la $(LIB_KIO)
+kio_opengroupware_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+