summaryrefslogtreecommitdiffstats
path: root/kpilot/conduits/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kpilot/conduits/CMakeLists.txt')
-rw-r--r--kpilot/conduits/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/kpilot/conduits/CMakeLists.txt b/kpilot/conduits/CMakeLists.txt
new file mode 100644
index 000000000..e8f49e53f
--- /dev/null
+++ b/kpilot/conduits/CMakeLists.txt
@@ -0,0 +1,35 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}/lib
+ ${CMAKE_SOURCE_DIR}/lib
+ ${CMAKE_CURRENT_BINARY_DIR}
+)
+
+add_subdirectory(abbrowserconduit)
+add_subdirectory(docconduit)
+add_subdirectory(knotes)
+add_subdirectory(memofileconduit)
+add_subdirectory(notepadconduit)
+add_subdirectory(null)
+add_subdirectory(popmail)
+add_subdirectory(sysinfoconduit)
+add_subdirectory(timeconduit)
+
+FIND_PATH( HAVE_CALENDARLOCAL_H "libkcal/calendarlocal.h" ${KDE3_INCLUDE_DIR} )
+
+IF (HAVE_CALENDARLOCAL_H)
+ add_subdirectory(vcalconduit)
+ELSE (HAVE_CALENDARLOCAL_H)
+ MESSAGE(STATUS "No KDE PIM development headers were found.")
+ENDIF (HAVE_CALENDARLOCAL_H)
+
+###
+#
+# MAL seems to be broken, or the MAL API has changed somewhat
+# since the last time that the conduit was compiled by the development
+# team. Since we don't use the conduit it is disabled.
+IF (MAL_FOUND)
+ add_subdirectory(malconduit)
+ELSE (MAL_FOUND)
+ MESSAGE(STATUS "Couldn't find mal. Won't be able to build malconduit")
+ENDIF (MAL_FOUND)
+