summaryrefslogtreecommitdiffstats
path: root/kpilot/conduits/malconduit/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kpilot/conduits/malconduit/Makefile.am')
-rw-r--r--kpilot/conduits/malconduit/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/kpilot/conduits/malconduit/Makefile.am b/kpilot/conduits/malconduit/Makefile.am
new file mode 100644
index 000000000..d8a222431
--- /dev/null
+++ b/kpilot/conduits/malconduit/Makefile.am
@@ -0,0 +1,18 @@
+### Makefile for the avantgo conduit
+###
+### The mal conduit is Copyright (C) 2002 by Reinhold Kainhofer
+
+
+INCLUDES= $(PISOCK_INCLUDE) $(MAL_INCLUDE) -I$(top_srcdir)/kpilot/lib $(all_includes)
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)
+service_DATA = mal_conduit.desktop
+kde_kcfg_DATA = malconduit.kcfg
+
+kde_module_LTLIBRARIES = conduit_mal.la
+
+conduit_mal_la_SOURCES = malconduitSettings.kcfgc mal-setup_dialog.ui mal-factory.cc mal-setup.cc mal-conduit.cc
+conduit_mal_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+conduit_mal_la_LIBADD = ../../lib/libkpilot.la $(MAL_LIB) $(LIB_KDEUI)
+