summaryrefslogtreecommitdiffstats
path: root/kpilot/conduits/null/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kpilot/conduits/null/Makefile.am')
-rw-r--r--kpilot/conduits/null/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/kpilot/conduits/null/Makefile.am b/kpilot/conduits/null/Makefile.am
new file mode 100644
index 000000000..c1057b4df
--- /dev/null
+++ b/kpilot/conduits/null/Makefile.am
@@ -0,0 +1,15 @@
+INCLUDES= $(PISOCK_INCLUDE) -I$(top_srcdir)/kpilot/lib $(all_includes)
+
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)
+service_DATA = null-conduit.desktop
+
+kde_module_LTLIBRARIES = conduit_null.la
+
+
+conduit_null_la_SOURCES = nullSettings.kcfgc setup_base.ui null-conduit.cc null-factory.cc
+conduit_null_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+conduit_null_la_LIBADD = ../../lib/libkpilot.la $(LIB_KDEUI)
+
+kde_kcfg_DATA = nullconduit.kcfg