summaryrefslogtreecommitdiffstats
path: root/kpilot/conduits/popmail/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kpilot/conduits/popmail/Makefile.am')
-rw-r--r--kpilot/conduits/popmail/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/kpilot/conduits/popmail/Makefile.am b/kpilot/conduits/popmail/Makefile.am
new file mode 100644
index 000000000..0e565805d
--- /dev/null
+++ b/kpilot/conduits/popmail/Makefile.am
@@ -0,0 +1,24 @@
+### Makefile for the popmail conduit
+###
+
+INCLUDES= $(PISOCK_INCLUDE) -I$(top_srcdir)/kpilot/lib $(all_includes)
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)
+service_DATA = popmail-conduit.desktop
+kde_kcfg_DATA = popmail.kcfg
+
+####### This part is very kpilot specific
+# you can add here more. This one gets installed
+kde_module_LTLIBRARIES = conduit_popmail.la
+
+# Which sources should be compiled for popmail_conduit
+conduit_popmail_la_SOURCES = popmailSettings.kcfgc setup-dialog.ui \
+ popmail-factory.cc setupDialog.cc \
+ popmail-conduit.cc
+conduit_popmail_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+conduit_popmail_la_LIBADD = ../../lib/libkpilot.la $(LIB_KIO)
+
+# this option you can leave out. Just, if you use "make dist", you need it
+noinst_HEADERS = popmail-conduit.h setupDialog.h
+