summaryrefslogtreecommitdiffstats
path: root/kpilot/conduits/timeconduit/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kpilot/conduits/timeconduit/Makefile.am')
-rw-r--r--kpilot/conduits/timeconduit/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/kpilot/conduits/timeconduit/Makefile.am b/kpilot/conduits/timeconduit/Makefile.am
new file mode 100644
index 000000000..6a58716a5
--- /dev/null
+++ b/kpilot/conduits/timeconduit/Makefile.am
@@ -0,0 +1,22 @@
+### Makefile for the time conduit
+###
+### The time conduit is Copyright (C) 2002 by Reinhold Kainhofer
+
+INCLUDES= $(PISOCK_INCLUDE) -I$(top_srcdir)/kpilot/lib $(all_includes)
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)
+service_DATA = time_conduit.desktop
+
+kde_module_LTLIBRARIES = conduit_time.la
+
+
+conduit_time_la_SOURCES = timeConduitSettings.kcfgc \
+ time-factory.cc \
+ time-setup.cc \
+ time-conduit.cc \
+ time-setup_dialog.ui
+conduit_time_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+conduit_time_la_LIBADD = ../../lib/libkpilot.la $(LIB_KDEUI)
+
+kde_kcfg_DATA = timeconduit.kcfg