summaryrefslogtreecommitdiffstats
path: root/kpilot/conduits/vcalconduit/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kpilot/conduits/vcalconduit/Makefile.am')
-rw-r--r--kpilot/conduits/vcalconduit/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/kpilot/conduits/vcalconduit/Makefile.am b/kpilot/conduits/vcalconduit/Makefile.am
new file mode 100644
index 000000000..546789e17
--- /dev/null
+++ b/kpilot/conduits/vcalconduit/Makefile.am
@@ -0,0 +1,43 @@
+###
+### Makefile for vcal and todo conduits. These two conduits share most code,
+### so it seems logical to put them in one place.
+###
+
+INCLUDES= -I$(top_srcdir)/kpilot/lib -I$(top_srcdir) \
+ $(PISOCK_INCLUDE) $(all_includes)
+
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)
+service_DATA = vcal-conduit.desktop todo-conduit.desktop
+
+kde_module_LTLIBRARIES = conduit_vcal.la conduit_todo.la
+noinst_LTLIBRARIES = libvcalconduit_shared.la
+
+libvcalconduit_shared_la_SOURCES = vcalconduitSettings.kcfgc \
+ korganizerConduit.ui \
+ kcalRecord.cc \
+ vcal-setupbase.cc \
+ vcal-conduitbase.cc \
+ cleanupstate.cc deleteunsyncedhhstate.cc deleteunsyncedpcstate.cc \
+ hhtopcstate.cc initstate.cc pctohhstate.cc teststate.cc
+
+conduit_vcal_la_SOURCES = vcal-conduit.cc vcalRecord.cc \
+ vcal-factory.cc vcal-setup.cc
+conduit_vcal_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+conduit_vcal_la_LIBADD = ../../lib/libkpilot.la \
+ ../../../libkcal/libkcal.la \
+ libvcalconduit_shared.la
+conduit_vcal_la_COMPILE_FIRST = vcalconduitSettings.h korganizerConduit.h
+
+conduit_todo_la_SOURCES = todo-conduit.cc todoRecord.cc \
+ todo-factory.cc todo-setup.cc
+conduit_todo_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+conduit_todo_la_LIBADD = ../../lib/libkpilot.la \
+ ../../../libkcal/libkcal.la \
+ libvcalconduit_shared.la
+conduit_todo_la_COMPILE_FIRST = vcalconduitSettings.h korganizerConduit.h
+
+
+kde_kcfg_DATA = vcalconduitbase.kcfg
+