summaryrefslogtreecommitdiffstats
path: root/kresources/kolab/kabc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kresources/kolab/kabc/CMakeLists.txt')
-rw-r--r--kresources/kolab/kabc/CMakeLists.txt54
1 files changed, 0 insertions, 54 deletions
diff --git a/kresources/kolab/kabc/CMakeLists.txt b/kresources/kolab/kabc/CMakeLists.txt
deleted file mode 100644
index e1d3bd40f..000000000
--- a/kresources/kolab/kabc/CMakeLists.txt
+++ /dev/null
@@ -1,54 +0,0 @@
-#################################################
-#
-# (C) 2010-2011 Serghei Amelian
-# serghei (DOT) amelian (AT) gmail.com
-#
-# Improvements and feedback are welcome
-#
-# This file is released under GPL >= 2
-#
-#################################################
-
-include_directories(
- ${CMAKE_CURRENT_BINARY_DIR}
- ${CMAKE_CURRENT_SOURCE_DIR}/../shared
- ${CMAKE_SOURCE_DIR}
- ${CMAKE_SOURCE_DIR}/libtdepim
- ${TDE_INCLUDE_DIR}
- ${TQT_INCLUDE_DIRS}
-)
-
-link_directories(
- ${TQT_LIBRARY_DIRS}
-)
-
-
-##### other data ################################
-
-install(
- FILES kolab.desktop
- DESTINATION ${SERVICES_INSTALL_DIR}/kresources/kabc )
-
-install(
- FILES ${CMAKE_CURRENT_SOURCE_DIR}/../uninstall.desktop
- DESTINATION ${SERVICES_INSTALL_DIR}/kresources/kabc
- RENAME imap.desktop )
-
-
-##### kabc_kolab (module) #######################
-
-tde_add_kpart( kabc_kolab AUTOMOC
- SOURCES resourcekolab_plugin.cpp
- LINK kabckolab-shared
- DESTINATION ${PLUGIN_INSTALL_DIR}
-)
-
-
-##### kabckolab (shared) ########################
-
-tde_add_library( kabckolab SHARED AUTOMOC
- SOURCES resourcekolab.cpp contact.cpp
- VERSION 0.0.0
- LINK resourcekolabshared-static kgroupwarebase-shared
- DESTINATION ${LIB_INSTALL_DIR}
-)