summaryrefslogtreecommitdiffstats
path: root/plugins/recording/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/recording/CMakeLists.txt')
-rw-r--r--plugins/recording/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/plugins/recording/CMakeLists.txt b/plugins/recording/CMakeLists.txt
new file mode 100644
index 0000000..8d9d382
--- /dev/null
+++ b/plugins/recording/CMakeLists.txt
@@ -0,0 +1,33 @@
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### recording (icons and translations)
+
+add_subdirectory( icons )
+tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
+
+
+##### recording (plugin)
+
+tde_add_kpart( librecording AUTOMOC
+ SOURCES
+ recording-configuration.cpp recording-configuration-ui.ui recording.cpp
+ recording-config.cpp reccfg_interfaces.cpp encoder.cpp recording-datamonitor.cpp
+ recording-monitor.cpp encoder_mp3.cpp encoder_ogg.cpp encoder_pcm.cpp
+
+ LINK tderadio-shared ${LAME_LIBRARIES} ${OGG_LIBRARIES} ${VORBIS_LIBRARIES}
+ ${VORBISFILE_LIBRARIES} ${VORBISENC_LIBRARIES} ${SNDFILE_LIBRARIES}
+ DESTINATION ${LIB_INSTALL_DIR}/${PROJECT_NAME}/plugins
+)