summaryrefslogtreecommitdiffstats
path: root/plugins/timecontrol/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/timecontrol/CMakeLists.txt')
-rw-r--r--plugins/timecontrol/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/plugins/timecontrol/CMakeLists.txt b/plugins/timecontrol/CMakeLists.txt
new file mode 100644
index 0000000..772612e
--- /dev/null
+++ b/plugins/timecontrol/CMakeLists.txt
@@ -0,0 +1,28 @@
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### timecontrol (icons and translations)
+
+add_subdirectory( icons )
+tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
+
+
+##### timecontrol (plugin)
+
+tde_add_kpart( libtimecontrol AUTOMOC
+ SOURCES timecontrol-configuration.cpp timecontrol-configuration-ui.ui timecontrol.cpp
+ LINK tderadio-shared
+ DESTINATION ${LIB_INSTALL_DIR}/${PROJECT_NAME}/plugins
+)