summaryrefslogtreecommitdiffstats
path: root/tderadio3/plugins/gui-error-log/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tderadio3/plugins/gui-error-log/Makefile.am')
-rw-r--r--tderadio3/plugins/gui-error-log/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/tderadio3/plugins/gui-error-log/Makefile.am b/tderadio3/plugins/gui-error-log/Makefile.am
new file mode 100644
index 0000000..1ac0e60
--- /dev/null
+++ b/tderadio3/plugins/gui-error-log/Makefile.am
@@ -0,0 +1,17 @@
+SUBDIRS = po .
+
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+libkradio_LTLIBRARIES = liberror-log.la
+liberror_log_la_SOURCES = errorlog.cpp
+liberror_log_la_LDFLAGS = -module -avoid-version $(KDE_RPATH) $(all_libraries)
+
+noinst_HEADERS = errorlog.h
+
+#messages: rc.cpp
+# $(XGETTEXT) *.cpp *.h -o po/kradio-gui-error-log.pot
+
+messages: rc.cpp
+ $(EXTRACTRC) *.rc *.ui >> rc.cpp
+ $(XGETTEXT) rc.cpp *.h *.cpp -o po/kradio-gui-error-log.pot