summaryrefslogtreecommitdiffstats
path: root/kbabel/common/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-16 18:30:12 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-17 02:50:29 +0200
commit7fa2dd79a4f7711a65b45724448c1529dfb94e9f (patch)
tree0192394f73f297cd56aa972df31bf8bfc07a71d3 /kbabel/common/CMakeLists.txt
parent29e1ae5e34974950ff7965b1522db70b4ff273dc (diff)
downloadtdesdk-7fa2dd79a4f7711a65b45724448c1529dfb94e9f.tar.gz
tdesdk-7fa2dd79a4f7711a65b45724448c1529dfb94e9f.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kbabel/common/CMakeLists.txt')
-rw-r--r--kbabel/common/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/kbabel/common/CMakeLists.txt b/kbabel/common/CMakeLists.txt
index d0377a65..2050d51c 100644
--- a/kbabel/common/CMakeLists.txt
+++ b/kbabel/common/CMakeLists.txt
@@ -35,7 +35,12 @@ install( FILES
##### other data ################################
-install( FILES kbabelfilter.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE kbabelfilter.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR kbabel-desktops
+)
+
install( FILES kbprojectsettings.kcfg DESTINATION ${KCFG_INSTALL_DIR} )
install( FILES kbabel-projectrename.upd DESTINATION ${KCONF_UPDATE_INSTALL_DIR} )