summaryrefslogtreecommitdiffstats
path: root/kbugbuster/backend/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-18 18:38:56 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-18 18:38:58 +0200
commitf49ad59af0fb02cb29968960cb6a380649dc07c6 (patch)
treea0e5ce9ad78b07ffc6c71bfd3cf89088f15ba222 /kbugbuster/backend/CMakeLists.txt
parent956b575acf57dacc1a058c881dcbcb4bf4a4011b (diff)
downloadtdesdk-f49ad59af0fb02cb29968960cb6a380649dc07c6.tar.gz
tdesdk-f49ad59af0fb02cb29968960cb6a380649dc07c6.zip
kbugbuster: Build only the PIC variant of the static backend library.
This should resolve the occasional FTBFS caused by double generation of the same MOC files. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kbugbuster/backend/CMakeLists.txt')
-rw-r--r--kbugbuster/backend/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/kbugbuster/backend/CMakeLists.txt b/kbugbuster/backend/CMakeLists.txt
index 64b8ca6b..cb3b83c2 100644
--- a/kbugbuster/backend/CMakeLists.txt
+++ b/kbugbuster/backend/CMakeLists.txt
@@ -26,12 +26,6 @@ set( SRCS
rdfprocessor.cpp htmlparser.cpp kbbprefs.cpp
)
-tde_add_library( kbbbackend_nopic STATIC AUTOMOC
+tde_add_library( kbbbackend STATIC_PIC AUTOMOC
SOURCES ${SRCS}
)
-
-if( WITH_KCAL )
- tde_add_library( kbbbackend_pic STATIC_PIC AUTOMOC
- SOURCES ${SRCS}
- )
-endif( )