summaryrefslogtreecommitdiffstats
path: root/kmtrace/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-09-15 22:18:04 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-09-15 22:42:00 +0200
commitcf63191672fff12cd57892ba4642ed4f01e9c6a4 (patch)
tree4464031464fe01f04c0f24bbc1181246519e1505 /kmtrace/CMakeLists.txt
parentf4582480b472d7551d8f867bae4c99a96c9d588d (diff)
downloadtdesdk-cf63191672fff12cd57892ba4642ed4f01e9c6a4.tar.gz
tdesdk-cf63191672fff12cd57892ba4642ed4f01e9c6a4.zip
Add a backtrace function and library detection.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kmtrace/CMakeLists.txt')
-rw-r--r--kmtrace/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/kmtrace/CMakeLists.txt b/kmtrace/CMakeLists.txt
index c2551b0e..126a1013 100644
--- a/kmtrace/CMakeLists.txt
+++ b/kmtrace/CMakeLists.txt
@@ -12,6 +12,7 @@
include_directories(
${TDE_INCLUDE_DIR}
${TQT_INCLUDE_DIRS}
+ ${CMAKE_BINARY_DIR}
)
link_directories(
@@ -21,6 +22,11 @@ link_directories(
set( LD_FLAGS "-Wl,-Bstatic -liberty -Wl,-Bdynamic" )
+##### configure checks ##########################
+
+include( ConfigureChecks.cmake )
+
+
##### other data ################################
configure_file( kminspector.cmake kminspector @ONLY )
@@ -48,7 +54,7 @@ tde_add_library( ktrace_s STATIC
tde_add_library( ktrace SHARED
SOURCES ksotrace.cpp ktrace.c
- LINK dl
+ LINK ${DL_LIBRARIES} ${Backtrace_LIBRARY}
DESTINATION ${LIB_INSTALL_DIR}/kmtrace
)