summaryrefslogtreecommitdiffstats
path: root/kompare/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-16 18:30:12 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-17 02:50:29 +0200
commit7fa2dd79a4f7711a65b45724448c1529dfb94e9f (patch)
tree0192394f73f297cd56aa972df31bf8bfc07a71d3 /kompare/CMakeLists.txt
parent29e1ae5e34974950ff7965b1522db70b4ff273dc (diff)
downloadtdesdk-7fa2dd79a4f7711a65b45724448c1529dfb94e9f.tar.gz
tdesdk-7fa2dd79a4f7711a65b45724448c1529dfb94e9f.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kompare/CMakeLists.txt')
-rw-r--r--kompare/CMakeLists.txt14
1 files changed, 10 insertions, 4 deletions
diff --git a/kompare/CMakeLists.txt b/kompare/CMakeLists.txt
index 4977eb71..2556897a 100644
--- a/kompare/CMakeLists.txt
+++ b/kompare/CMakeLists.txt
@@ -35,12 +35,18 @@ link_directories(
##### other data ################################
-install( FILES kompare.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE kompare.desktop
+ PO_DIR kompare-desktops
+)
+
install( FILES kompareui.rc DESTINATION ${DATA_INSTALL_DIR}/kompare )
-install( FILES
- komparenavigationpart.desktop kompareviewpart.desktop
- DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE komparenavigationpart.desktop kompareviewpart.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR kompare-desktops
+)
##### kompare (executable) ######################