summaryrefslogtreecommitdiffstats
path: root/tdeunittest/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:59 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:59 -0600
commit1515a4f2eb9cf023ed7f9c2e10106b5e93164a08 (patch)
treed5617734090b254659ff331ce7d1e574c4807caf /tdeunittest/CMakeLists.txt
parentf8069e2ea048f2657cc417d83820576ec55c181b (diff)
downloadtdesdk-1515a4f2eb9cf023ed7f9c2e10106b5e93164a08.tar.gz
tdesdk-1515a4f2eb9cf023ed7f9c2e10106b5e93164a08.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeunittest/CMakeLists.txt')
-rw-r--r--tdeunittest/CMakeLists.txt50
1 files changed, 50 insertions, 0 deletions
diff --git a/tdeunittest/CMakeLists.txt b/tdeunittest/CMakeLists.txt
new file mode 100644
index 00000000..2a4e1f5a
--- /dev/null
+++ b/tdeunittest/CMakeLists.txt
@@ -0,0 +1,50 @@
+#################################################
+#
+# (C) 2012 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### headers ###################################
+
+install( FILES
+ runnergui.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/tdeunittest )
+
+install( PROGRAMS
+ tdeunittest tdeunittestmod tdeunittest_debughelper
+ DESTINATION ${BIN_INSTALL_DIR} )
+
+
+##### tdeunittestgui (shared) #####################
+
+tde_add_library( tdeunittestgui SHARED AUTOMOC
+ SOURCES testerwidget.ui runnergui.cpp dcopinterface.skel
+ VERSION 0.0.0
+ LINK tdeunittest-shared
+ DESTINATION ${LIB_INSTALL_DIR}
+)
+
+
+##### tdeunittestguimodrunner (executable) ########
+
+tde_add_executable( tdeunittestguimodrunner
+ SOURCES guimodrunner.cpp
+ LINK tdeunittestgui-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)