summaryrefslogtreecommitdiffstats
path: root/kbabel/common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kbabel/common/CMakeLists.txt')
-rw-r--r--kbabel/common/CMakeLists.txt63
1 files changed, 63 insertions, 0 deletions
diff --git a/kbabel/common/CMakeLists.txt b/kbabel/common/CMakeLists.txt
new file mode 100644
index 00000000..f6b6fd96
--- /dev/null
+++ b/kbabel/common/CMakeLists.txt
@@ -0,0 +1,63 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( libgettext )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### headers ###################################
+
+install( FILES
+ catalog.h catalogitem.h editcmd.h msgfmt.h catalogsettings.h
+ findoptions.h catalogview.h tagextractor.h poinfo.h regexpextractor.h
+ itempart.h catalogfileplugin.h kbabeldatatool.h kbproject.h
+ kbprojectmanager.h projectsettings.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/kbabel )
+
+
+##### other data ################################
+
+install( FILES kbabelfilter.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+install( FILES kbprojectsettings.kcfg DESTINATION ${KCFG_INSTALL_DIR} )
+install( FILES kbabel-projectrename.upd DESTINATION ${KCONF_UPDATE_INSTALL_DIR} )
+
+
+##### kbabelcommon (shared) #####################
+
+add_custom_command( OUTPUT version.h
+ COMMAND echo \"/* Generated file - DO NOT EDIT */\" > version.h
+ COMMAND echo \"\#undef VERSION\" >> version.h
+ COMMAND echo \"\#define VERSION \\\"`cat ${CMAKE_CURRENT_SOURCE_DIR}/../VERSION`\\\"\" >> version.h
+ DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/../VERSION )
+
+set_source_files_properties( catalog.cpp PROPERTIES OBJECT_DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/version.h )
+
+tde_add_library( kbabelcommon SHARED AUTOMOC
+ SOURCES
+ catalog.cpp catalogitem.cpp editcmd.cpp msgfmt.cpp
+ catalogsettings.cpp tagextractor.cpp diff.cpp argextractor.cpp
+ kbmailer.cpp poinfo.cpp regexpextractor.cpp importplugin.cpp
+ exportplugin.cpp kbproject.cpp kbprojectmanager.cpp
+ kbprojectsettings.kcfgc projectsettings.cpp stringdistance.cpp
+ VERSION 3.2.0
+ LINK gettext-static kio-shared
+ DESTINATION ${LIB_INSTALL_DIR}
+)