summaryrefslogtreecommitdiffstats
path: root/umbrello/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'umbrello/CMakeLists.txt')
-rw-r--r--umbrello/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/umbrello/CMakeLists.txt b/umbrello/CMakeLists.txt
new file mode 100644
index 00000000..5429f5a4
--- /dev/null
+++ b/umbrello/CMakeLists.txt
@@ -0,0 +1,19 @@
+#################################################
+#
+# (C) 2012 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include( ConfigureChecks.cmake )
+
+# generate version.h
+file( READ VERSION text )
+string( REGEX REPLACE "\n" "" text "${text}" )
+file( WRITE ${CMAKE_CURRENT_BINARY_DIR}/version.h "#define UMBRELLO_VERSION \"${text}\"\n" )
+
+add_subdirectory( umbrello )