summaryrefslogtreecommitdiffstats
path: root/kteatime/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitae2a03c2941bf92573f89b88ef73f8aa842bea0a (patch)
tree3566563f3fb6ac3cb3496669d8f233062d3091bc /kteatime/Makefile.am
downloadtdetoys-ae2a03c2941bf92573f89b88ef73f8aa842bea0a.tar.gz
tdetoys-ae2a03c2941bf92573f89b88ef73f8aa842bea0a.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdetoys@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kteatime/Makefile.am')
-rw-r--r--kteatime/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/kteatime/Makefile.am b/kteatime/Makefile.am
new file mode 100644
index 0000000..82ebf40
--- /dev/null
+++ b/kteatime/Makefile.am
@@ -0,0 +1,27 @@
+
+INCLUDES= $(all_includes)
+
+bin_PROGRAMS = kteatime
+
+kteatime_SOURCES = main.cpp toplevel.cpp tealist.cpp timeedit.cpp
+
+kteatime_METASOURCES = AUTO
+kteatime_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+
+# LIB_KIO needed for KNotifyDialog
+kteatime_LDADD = $(LIB_KDEUI) $(LIB_KIO)
+
+KDE_ICON = kteatime
+
+KDE_OPTIONS = nofinal
+
+appsdata_DATA = eventsrc
+appsdatadir = $(kde_datadir)/kteatime
+
+kteatimeicondir = $(kde_datadir)/kteatime/icons
+kteatimeicon_ICON = AUTO
+
+messages:
+ $(XGETTEXT) $(kteatime_SOURCES) -o $(podir)/kteatime.pot
+
+xdg_apps_DATA = kteatime.desktop