summaryrefslogtreecommitdiffstats
path: root/khexedit/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorDarrell Anderson <humanreadable@yahoo.com>2012-11-10 20:47:02 -0600
committerDarrell Anderson <humanreadable@yahoo.com>2012-11-10 20:47:02 -0600
commitc1a8ee04fbfe9851c1f788bcdcf3a5339ce1e478 (patch)
treeb60bf0191b08974e1ad29fd808d298aaeb29ef5a /khexedit/lib/CMakeLists.txt
parent42177b2709de3eb2ef8ecde7d2a027fbb05a218c (diff)
downloadtdeutils-c1a8ee04fbfe9851c1f788bcdcf3a5339ce1e478.tar.gz
tdeutils-c1a8ee04fbfe9851c1f788bcdcf3a5339ce1e478.zip
Initial conversion to cmake.
Thanks to Fat-Zer.
Diffstat (limited to 'khexedit/lib/CMakeLists.txt')
-rw-r--r--khexedit/lib/CMakeLists.txt52
1 files changed, 52 insertions, 0 deletions
diff --git a/khexedit/lib/CMakeLists.txt b/khexedit/lib/CMakeLists.txt
new file mode 100644
index 0000000..7d16b3d
--- /dev/null
+++ b/khexedit/lib/CMakeLists.txt
@@ -0,0 +1,52 @@
+#################################################
+#
+# (C) 2012 Golubev Alexander
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( controller )
+add_subdirectory( codecs )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${CMAKE_CURRENT_BINARY_DIR}/controller
+ ${CMAKE_CURRENT_BINARY_DIR}/codecs
+)
+
+
+##### khexeditcommon (shared) ###################
+
+tde_add_library( khexeditcommon SHARED AUTOMOC
+ SOURCES kcolumn.cpp kbordercolumn.cpp
+ koffsetcolumn.cpp kbuffercolumn.cpp
+ kvaluecolumn.cpp kcharcolumn.cpp
+ kcolumnsview.cpp khexedit.cpp kbytesedit.cpp
+ koffsetformat.cpp kdatabuffer.cpp
+ kwrappingrobuffer.cpp kplainbuffer.cpp
+ kfixedsizebuffer.cpp kbigbuffer.cpp
+ kbuffercursor.cpp kbufferlayout.cpp
+ kbufferranges.cpp kcursor.cpp kbufferdrag.cpp
+ kwordbufferservice.cpp ksectionlist.cpp
+ kcoordrangelist.cpp kbordercoltextexport.cpp
+ koffsetcoltextexport.cpp
+ kbuffercoltextexport.cpp
+ kvaluecoltextexport.cpp
+ kcharcoltextexport.cpp
+ LINK tdecore-shared kcontroller-static
+ khecodecs-static
+ DESTINATION ${LIB_INSTALL_DIR}
+)
+