summaryrefslogtreecommitdiffstats
path: root/khexedit/lib/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit2bda8f7717adf28da4af0d34fb82f63d2868c31d (patch)
tree8d927b7b47a90c4adb646482a52613f58acd6f8c /khexedit/lib/Makefile.am
downloadtdeutils-2bda8f7717adf28da4af0d34fb82f63d2868c31d.tar.gz
tdeutils-2bda8f7717adf28da4af0d34fb82f63d2868c31d.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeutils@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'khexedit/lib/Makefile.am')
-rw-r--r--khexedit/lib/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/khexedit/lib/Makefile.am b/khexedit/lib/Makefile.am
new file mode 100644
index 0000000..c0c92cc
--- /dev/null
+++ b/khexedit/lib/Makefile.am
@@ -0,0 +1,39 @@
+SUBDIRS = controller codecs
+
+INCLUDES = $(all_includes)
+
+METASOURCES = AUTO
+
+# this library is used by the kbytesedit part and the khepart part
+lib_LTLIBRARIES = libkhexeditcommon.la
+libkhexeditcommon_la_LDFLAGS = $(all_libraries) -no-undefined
+libkhexeditcommon_la_LIBADD = controller/libkcontroller.la codecs/libkhecodecs.la $(LIB_KDECORE)
+libkhexeditcommon_la_SOURCES = kcolumn.cpp kbordercolumn.cpp koffsetcolumn.cpp \
+ kbuffercolumn.cpp kvaluecolumn.cpp kcharcolumn.cpp \
+ kcolumnsview.cpp khexedit.cpp kbytesedit.cpp \
+ koffsetformat.cpp \
+ kdatabuffer.cpp kwrappingrobuffer.cpp \
+ kplainbuffer.cpp kfixedsizebuffer.cpp kbigbuffer.cpp \
+ kbuffercursor.cpp kbufferlayout.cpp kbufferranges.cpp \
+ kcursor.cpp kbufferdrag.cpp \
+ kwordbufferservice.cpp \
+ ksectionlist.cpp kcoordrangelist.cpp \
+ kbordercoltextexport.cpp koffsetcoltextexport.cpp \
+ kbuffercoltextexport.cpp kvaluecoltextexport.cpp kcharcoltextexport.cpp
+
+# no public API for a direct use by now
+noinst_HEADERS = kcolumn.h kbordercolumn.h koffsetcolumn.h \
+ kbuffercolumn.h kvaluecolumn.h kcharcolumn.h \
+ kbytecodec.h koffsetformat.h khexedit_export.h \
+ kbuffercursor.h kbufferlayout.h kbufferranges.h \
+ kbuffercoord.h kselection.h \
+ kcursor.h kbufferdrag.h \
+ kcoordrange.h ksectionlist.h kcoordrangelist.h \
+ khechar.h kcharcodec.h \
+ kcoltextexport.h kbordercoltextexport.h koffsetcoltextexport.h \
+ kbuffercoltextexport.h kvaluecoltextexport.h kcharcoltextexport.h \
+ kadds.h khe.h krange.h ksection.h \
+ kwordbufferservice.h \
+ kcolumnsview.h khexedit.h kbytesedit.h \
+ kplainbuffer.h kfixedsizebuffer.h kbigbuffer.h \
+ kdatabuffer.h kreadonlybuffer.h kwrappingrobuffer.h