summaryrefslogtreecommitdiffstats
path: root/languages/cpp/app_templates/cmakelibc/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2015-06-15 13:15:26 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2015-06-15 13:15:26 +0900
commit065693194f81b16c3d6deb7fb70a07ae0e884eb6 (patch)
tree0fee01815f662918c086c164005c812829829159 /languages/cpp/app_templates/cmakelibc/CMakeLists.txt
parentf817dc21e2258793f3f91aa6c0e916d29e9449e4 (diff)
downloadtdevelop-065693194f81b16c3d6deb7fb70a07ae0e884eb6.tar.gz
tdevelop-065693194f81b16c3d6deb7fb70a07ae0e884eb6.zip
Fix cmake template project files. This relates to bug 2308.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'languages/cpp/app_templates/cmakelibc/CMakeLists.txt')
-rw-r--r--languages/cpp/app_templates/cmakelibc/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/languages/cpp/app_templates/cmakelibc/CMakeLists.txt b/languages/cpp/app_templates/cmakelibc/CMakeLists.txt
index 841853d8..9db2bf91 100644
--- a/languages/cpp/app_templates/cmakelibc/CMakeLists.txt
+++ b/languages/cpp/app_templates/cmakelibc/CMakeLists.txt
@@ -10,9 +10,10 @@
#################################################
add_custom_target( cmakelibc.tar.gz ALL
- COMMAND tar zcf cmakelibc.tar.gz -C ${CMAKE_CURRENT_SOURCE_DIR}
- test.c lib.h lib.c cmakelibc.png cmakelibc-CMakeLists.txt
- CMakeLists.txt.src
+ COMMAND tar --transform \"flags=r\;s/cmakelibc-CMakeLists.txt/CMakeLists.txt/\"
+ -zcf cmakelibc.tar.gz -C ${CMAKE_CURRENT_SOURCE_DIR}
+ test.c lib.h lib.c cmakelibc.png cmakelibc-CMakeLists.txt
+ CMakeLists.txt.src
)