summaryrefslogtreecommitdiffstats
path: root/lib/interfaces/extras/CMakeLists.txt
diff options
context:
space:
mode:
authorsamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-01-23 20:22:40 +0000
committersamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-01-23 20:22:40 +0000
commitcf21ddc3cce570e574364e841758b59c0f8e8e04 (patch)
tree9f79e4569bb2991b4de8c25dd23795126ac0914c /lib/interfaces/extras/CMakeLists.txt
parentf9c30e41d26594598abaa8315c4488b6c5ff38ea (diff)
downloadtdevelop-cf21ddc3cce570e574364e841758b59c0f8e8e04.tar.gz
tdevelop-cf21ddc3cce570e574364e841758b59c0f8e8e04.zip
[kdevelop] initial cmake support
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdevelop@1216516 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'lib/interfaces/extras/CMakeLists.txt')
-rw-r--r--lib/interfaces/extras/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/lib/interfaces/extras/CMakeLists.txt b/lib/interfaces/extras/CMakeLists.txt
new file mode 100644
index 00000000..522a9c10
--- /dev/null
+++ b/lib/interfaces/extras/CMakeLists.txt
@@ -0,0 +1,40 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### headers ###################################
+
+install( FILES
+ kdevcompileroptions.h kdevvcsintegrator.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/kdevelop/interfaces/extras )
+
+install( FILES
+ kdevelopcompileroptions.desktop kdevelopvcsintegrator.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+
+
+##### kdevextras (shared) #######################
+
+tde_add_library( kdevextras SHARED AUTOMOC
+ SOURCES kdevcompileroptions.cpp kdevvcsintegrator.cpp
+ VERSION 0.0.0
+ LINK ${TQT_LIBRARIES}
+ DESTINATION ${LIB_INSTALL_DIR}
+)