summaryrefslogtreecommitdiffstats
path: root/lib/interfaces/extras/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-29 22:43:34 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-30 16:00:07 +0200
commitfe44776673b28ca94338f23d8e7ac71593fa88ba (patch)
treeb900146c853acbd44900bfb77a35a1af3c77aa5d /lib/interfaces/extras/CMakeLists.txt
parentc0b663c4c873df495743600b8f703744420eddfa (diff)
downloadtdevelop-fe44776673b28ca94338f23d8e7ac71593fa88ba.tar.gz
tdevelop-fe44776673b28ca94338f23d8e7ac71593fa88ba.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'lib/interfaces/extras/CMakeLists.txt')
-rw-r--r--lib/interfaces/extras/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/lib/interfaces/extras/CMakeLists.txt b/lib/interfaces/extras/CMakeLists.txt
index eb4cdb75..5ae51881 100644
--- a/lib/interfaces/extras/CMakeLists.txt
+++ b/lib/interfaces/extras/CMakeLists.txt
@@ -25,9 +25,11 @@ install( FILES
kdevcompileroptions.h kdevvcsintegrator.h
DESTINATION ${INCLUDE_INSTALL_DIR}/tdevelop/interfaces/extras )
-install( FILES
- tdevelopcompileroptions.desktop tdevelopvcsintegrator.desktop
- DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE tdevelopcompileroptions.desktop tdevelopvcsintegrator.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR tdevelop-desktops
+)
##### kdevextras (shared) #######################