summaryrefslogtreecommitdiffstats
path: root/src/newui/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2012-11-17 16:06:35 +0100
committerSlávek Banko <slavek.banko@axis.cz>2012-11-17 16:06:51 +0100
commit96f0726b226f4b404c38f998fbdd02cf728ba6e8 (patch)
tree4984d79f9a7fd23d6cb7fe67c4f4d97937cd2a0e /src/newui/CMakeLists.txt
parent5bca232c7d53e3bc28dae36b0ccc9dbcbbf01fba (diff)
downloadtdevelop-96f0726b226f4b404c38f998fbdd02cf728ba6e8.tar.gz
tdevelop-96f0726b226f4b404c38f998fbdd02cf728ba6e8.zip
Fix various cmake build issues
Diffstat (limited to 'src/newui/CMakeLists.txt')
-rw-r--r--src/newui/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/newui/CMakeLists.txt b/src/newui/CMakeLists.txt
index b65bff6a..046c2c7f 100644
--- a/src/newui/CMakeLists.txt
+++ b/src/newui/CMakeLists.txt
@@ -16,10 +16,13 @@ include_directories(
)
-##### d (static) ################################
+##### d (shared) ################################
-tde_add_library( d STATIC_PIC AUTOMOC
+tde_add_library( d SHARED AUTOMOC
SOURCES
dmainwindow.cpp buttonbar.cpp button.cpp ddockwindow.cpp
docksplitter.cpp dtabwidget.cpp
+ LINK kparts-shared tdecore-shared tdeui-shared
+ VERSION 0.0.0
+ DESTINATION ${LIB_INSTALL_DIR}
)