summaryrefslogtreecommitdiffstats
path: root/klinkstatus/src/ui/settings/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <g-gregory@gmx.fr>2019-06-28 15:14:51 +0200
committergregory guy <gregory-tde@laposte.net>2021-03-11 15:04:14 +0100
commit4c43d1fbb66a296958ed1d0dbddf3f8ac4466130 (patch)
treee532b01e8168b2f849f8aaa3266a58b088705726 /klinkstatus/src/ui/settings/CMakeLists.txt
parent10d21d001e92e653cec6b6d1c05983abd00a1195 (diff)
downloadtdewebdev-4c43d1fbb66a296958ed1d0dbddf3f8ac4466130.tar.gz
tdewebdev-4c43d1fbb66a296958ed1d0dbddf3f8ac4466130.zip
Conversion to the cmake building system.
Delete empty files (dummy.cpp, xsldbgconfig.h). Remove hard-coded path for the kmdr-executor executable. Replaced $TQTDIR/doc/html string path for TQTDOCDIR in kommander. Add man pages taken from the Debian packaging. Signed-off-by: gregory guy <gregory-tde@laposte.net> Fix linking - kxsldbgcommon-static and kimagemapeditorcommon-static needs to be embedded. Move the linking of xml and readline libraries to the appropriate static libraries. Add build option WITH_QUANTA_CVSSERVICE. Add a test whether the readline can be linked standalone or whether ncurses is needed. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'klinkstatus/src/ui/settings/CMakeLists.txt')
-rw-r--r--klinkstatus/src/ui/settings/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/klinkstatus/src/ui/settings/CMakeLists.txt b/klinkstatus/src/ui/settings/CMakeLists.txt
new file mode 100644
index 00000000..d1fb1f3d
--- /dev/null
+++ b/klinkstatus/src/ui/settings/CMakeLists.txt
@@ -0,0 +1,32 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_BINARY_DIR}/klinkstatus/src/cfg
+ ${CMAKE_BINARY_DIR}/klinkstatus/src
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### settings (static)
+
+file( WRITE ${CMAKE_CURRENT_BINARY_DIR}/dummy.cpp "" )
+
+tde_add_library( settings STATIC_PIC AUTOMOC
+
+ SOURCES
+ configsearchdialog.ui
+ configresultsdialog.ui
+ configidentificationdialogui.ui
+ ${CMAKE_CURRENT_BINARY_DIR}/dummy.cpp
+ configidentificationdialog.cpp
+
+ DEPENDENCIES
+ cfg-static
+)