summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-30 13:45:25 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-30 13:45:34 +0200
commit5f344470718aafe87173d37c3bf4e1ce18fc0547 (patch)
tree1954d72c2773178204e2ce975837662ace8874c9 /CMakeLists.txt
parent6f630a485b5575044a6b1e94fa10de4bac19800b (diff)
downloadtdmtheme-r14.0.11.tar.gz
tdmtheme-r14.0.11.zip
Use common rules for build and install documentation and translations.r14.0.11
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 11b03c94ac7752c78a0844ec594bf791d783a732)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 69d3773..7a7958b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,8 +69,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files