summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-30 13:45:25 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-30 13:45:25 +0200
commit11b03c94ac7752c78a0844ec594bf791d783a732 (patch)
treebf1b9eb567107a0405adc54962377213f2e533ad /CMakeLists.txt
parent8fca4c9ea32fd1039372a0ff22f1e7b5245cbf86 (diff)
downloadtdmtheme-11b03c94ac7752c78a0844ec594bf791d783a732.tar.gz
tdmtheme-11b03c94ac7752c78a0844ec594bf791d783a732.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 51e070b..5ebf0b7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,8 +69,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files