summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2014-03-03 13:46:44 +0100
committerSlávek Banko <slavek.banko@axis.cz>2014-03-03 13:46:44 +0100
commit2e02da046d3e56cdf4744f644af35ad07424f48b (patch)
treef2dcf353aa2338eae1c2ff2c41af971c580c2762 /configure.in
parent3c13229d98167ae4ae0710d5eeef23fef5005bf0 (diff)
downloadtellico-2e02da046d3e56cdf4744f644af35ad07424f48b.tar.gz
tellico-2e02da046d3e56cdf4744f644af35ad07424f48b.zip
Update to upstream version 1.3.6
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in38
1 files changed, 33 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 8b6a1bf..388fbfa 100644
--- a/configure.in
+++ b/configure.in
@@ -40,7 +40,7 @@ dnl Perform program name transformation
AC_ARG_PROGRAM
dnl Automake doc recommends to do this only here. (Janos)
-AM_INIT_AUTOMAKE(tellico, 1.3.2.1) dnl searches for some needed programs
+AM_INIT_AUTOMAKE(tellico, 1.3.6) dnl searches for some needed programs
KDE_SET_PREFIX
@@ -491,7 +491,8 @@ AC_ARG_WITH([ooo-dir],
AC_HELP_STRING([--with-ooo-dir=DIR],
[where the OpenOffice.org program files are installed]),
[ac_ooo_libdir="${withval}/program"
- ac_ooo_datadir="${withval}/program"])
+ ac_ooo_datadir="${withval}/program"
+ ac_ooo_basisdir="${withval}/basis3.0"])
AC_ARG_WITH([ooo-libdir],
AC_HELP_STRING([--with-ooo-libdir=DIR],
[where the OpenOffice.org program libraries are installed (<ooo-dir>/program)]),
@@ -542,6 +543,13 @@ AC_CHECK_FILE([$ac_ooo_datadir/types.rdb],
[OFFICE_registry="$ac_ooo_datadir"/types.rdb],
AC_MSG_ERROR([[types.rdb not found, try '--with-ooo-dir=OpenOffice.org_installation_path']]))
+AC_FIND_FILE([offapi.rdb],
+ [$ac_ooo_basisdir/program $ac_ooo_libdir $ac_ooo_datadir],
+ offapi_dir)
+if test "$offapi_dir" != "NO"; then
+ OFFICE_registry="$OFFICE_registry $offapi_dir/offapi.rdb"
+fi
+
dnl Substitute the values
AC_SUBST(OFFICE_SDK_includes)
AC_SUBST(OFFICE_libadd)
@@ -562,7 +570,7 @@ AC_ARG_ENABLE(exempi,
)
if test x$enable_libexempi = xyes; then
- KDE_PKG_CHECK_MODULES(EXEMPI,
+ KDE_PKG_CHECK_MODULES(EXEMPI,
[exempi-2.0 >= 1.99.0],
[have_exempi=yes],
[have_exempi=no])
@@ -586,8 +594,8 @@ AC_ARG_ENABLE(poppler,
)
if test x$enable_libpoppler = xyes; then
- KDE_PKG_CHECK_MODULES(POPPLER,
- [poppler-qt >= 0.5],
+ KDE_PKG_CHECK_MODULES(POPPLER,
+ [poppler-tqt >= 0.5],
[have_poppler=yes],
[have_poppler=no])
AC_SUBST(POPPLER_LIBS)
@@ -609,12 +617,32 @@ AC_ARG_ENABLE(webcam,
[enable_webcam=no]
)
+if test x$enable_webcam = xyes; then
+ KDE_CHECK_HEADERS([linux/videodev.h],
+ [],
+ [enable_webcam="no"])
+fi
+
AM_CONDITIONAL(ENABLE_WEBCAM, test $enable_webcam = yes)
if test x$enable_webcam = xyes; then
AC_DEFINE(ENABLE_WEBCAM, 1, [Define to 1 if webcam support is enabled])
fi
dnl ---------- END WEBCAM CHECK ----------
+
+dnl ---------- SAX CHECK ----------
+
+AC_ARG_ENABLE(sax,
+ AC_HELP_STRING([--enable-sax], [enable SAX document loading (experimental), default=disable]),
+ [enable_sax=$enableval],
+ [enable_sax=no]
+)
+
+if test x$enable_sax = xyes; then
+ AC_DEFINE(SAX_SUPPORT, 1, [Define to 1 if the XML loader should use SAX])
+fi
+
+dnl ---------- END SAX CHECK ----------
KDE_CREATE_SUBDIRSLIST
AC_CONFIG_FILES([ Makefile ])
AC_CONFIG_FILES([ doc/Makefile ])