summaryrefslogtreecommitdiffstats
path: root/src/core/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/core/Makefile.am')
-rw-r--r--src/core/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/core/Makefile.am b/src/core/Makefile.am
new file mode 100644
index 0000000..2d61d84
--- /dev/null
+++ b/src/core/Makefile.am
@@ -0,0 +1,27 @@
+AM_CPPFLAGS = $(all_includes)
+
+noinst_LIBRARIES = libcore.a
+libcore_a_SOURCES = dcopinterface.cpp dcopinterface.skel drophandler.cpp \
+ netaccess.cpp tellico_config.cpp tellico_config.kcfgc tellico_config_addons.cpp
+
+libcore_a_METASOURCES = AUTO
+
+KDE_OPTIONS = noautodist
+
+EXTRA_DIST = \
+tellico_config.kcfg tellico_config.kcfgc \
+tellico_config_addons.h tellico_config_addons.cpp \
+dcopinterface.h dcopinterface.cpp \
+netaccess.h netaccess.cpp \
+drophandler.h drophandler.cpp \
+tellico-rename.upd tellico.upd \
+tellico-1-3-update.pl
+
+kde_kcfg_DATA = tellico_config.kcfg
+
+updatedir = $(kde_datadir)/kconf_update
+update_DATA = tellico-rename.upd tellico.upd
+update_SCRIPTS = tellico-1-3-update.pl
+
+CLEANFILES = *~ *.loT tellico_config.h tellico_config.cpp
+