summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-05-07 12:30:46 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-05-19 22:13:14 +0200
commit4743f46bfe645fcf4d39281c03e657cb87c0de5f (patch)
tree871fe556b3a8a487185d008d39f6edb6d2a9db91 /CMakeLists.txt
parent0b951a4b52422787f8fbcd9de0e1cd732f588323 (diff)
downloadtqca-4743f46bfe645fcf4d39281c03e657cb87c0de5f.tar.gz
tqca-4743f46bfe645fcf4d39281c03e657cb87c0de5f.zip
Add tqca-tls plugin to the tqca package.
Signed-off-by: gregory guy <gregory-tde@laposte.net> Signed-off-by: Slavek Banko <slavek.banko@axis.cz> (cherry picked from commit 99ec4964d0e4bfeed080f0a8d3661882f136d018)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 466b494..db2bcaa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -50,6 +50,13 @@ option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+##### user requested modules
+
+option( BUILD_ALL "Build all" ON )
+option( BUILD_TQCA "Build tqca shared lib" ${BUILD_ALL} )
+option( BUILD_TQCA_TLS "Build tqca-tls plugin" ${BUILD_ALL} )
+
+
##### configure checks
include( ConfigureChecks.cmake )
@@ -66,7 +73,8 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### source directories
-add_subdirectory( src )
+tde_conditional_add_subdirectory( BUILD_TQCA src )
+tde_conditional_add_subdirectory( BUILD_TQCA_TLS src/tls )
##### write configure files