summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f76e9e8..4f7ea5d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -50,6 +50,13 @@ option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+##### user requested modules
+
+option( BUILD_ALL "Build all" ON )
+option( BUILD_TQCA "Build tqca shared lib" ${BUILD_ALL} )
+option( BUILD_TQCA_TLS "Build tqca-tls plugin" ${BUILD_ALL} )
+
+
##### configure checks
include( ConfigureChecks.cmake )
@@ -66,7 +73,8 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### source directories
-add_subdirectory( src )
+tde_conditional_add_subdirectory( BUILD_TQCA src )
+tde_conditional_add_subdirectory( BUILD_TQCA_TLS src/tls )
##### write configure files