summaryrefslogtreecommitdiffstats
path: root/example/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'example/CMakeLists.txt')
-rw-r--r--example/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/example/CMakeLists.txt b/example/CMakeLists.txt
new file mode 100644
index 0000000..9512ae3
--- /dev/null
+++ b/example/CMakeLists.txt
@@ -0,0 +1,24 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_SOURCE_DIR}/qt
+ ${CMAKE_SOURCE_DIR}/src
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### app (executable)
+
+tde_add_executable( app AUTOMOC
+
+ SOURCES
+ application.cpp
+ main.cpp
+ LINK
+ qscintilla-shared
+)