summaryrefslogtreecommitdiffstats
path: root/qtinterface/CMakeLists.txt
diff options
context:
space:
mode:
authorOBATA Akio <obache@wizdas.com>2023-11-13 14:09:22 +0900
committerOBATA Akio <obache@wizdas.com>2023-11-13 14:11:03 +0900
commit73e6afa2ee2871d3cf47df6cea6d818876bd3642 (patch)
tree72d65a40135a73e28c51d8364eb7376eae4a1668 /qtinterface/CMakeLists.txt
parentd0e6f238acec8dd816618b0e9cf16eec498b573f (diff)
downloadtqtinterface-73e6afa2ee2871d3cf47df6cea6d818876bd3642.tar.gz
tqtinterface-73e6afa2ee2871d3cf47df6cea6d818876bd3642.zip
Change to build and install inputmethod files if enabled
Signed-off-by: OBATA Akio <obache@wizdas.com>
Diffstat (limited to 'qtinterface/CMakeLists.txt')
-rw-r--r--qtinterface/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/qtinterface/CMakeLists.txt b/qtinterface/CMakeLists.txt
index db7a8ec..8e88317 100644
--- a/qtinterface/CMakeLists.txt
+++ b/qtinterface/CMakeLists.txt
@@ -27,6 +27,10 @@ link_directories(
${TQT_LIBRARY_DIR}
)
+if ( INPUTMETHOD_ENABLED )
+ set( INPUTMETHOD_HEADERS ${IFACE}/tqinputcontext.h ${IFACE}/tqinputcontextfactory.h ${IFACE}/tqinputcontextplugin.h )
+ set( INPUTMETHOD_SOURCES ${IFACE}/tqinputcontext.cpp ${IFACE}/tqinputcontextfactory.cpp ${IFACE}/tqinputcontextplugin.cpp )
+endif()
##### headers ###################################
@@ -88,6 +92,7 @@ install( FILES
${IFACE}/private/tqlayoutengine_p.h ${IFACE}/private/tqinternal_p.h ${IFACE}/private/tqeffects_p.h
${IFACE}/private/tqrichtext_p.h ${IFACE}/private/tqpluginmanager_p.h ${IFACE}/private/tqcom_p.h
${IFACE}/private/tqucom_p.h ${IFACE}/private/tqwidgetinterface_p.h ${IFACE}/private/tqtextengine_p.h
+ ${INPUTMETHOD_HEADERS}
DESTINATION ${INCLUDE_INSTALL_DIR} )
##### tqt tools #################################
@@ -185,6 +190,7 @@ tde_add_library( tqt SHARED
${IFACE}/tqvaluelist.cpp ${IFACE}/tqvaluestack.cpp ${IFACE}/tqvaluevector.cpp ${IFACE}/tqvariant.cpp ${IFACE}/tqvfbhdr.cpp
${IFACE}/tqwaitcondition.cpp ${IFACE}/tqwhatsthis.cpp ${IFACE}/tqwidgetfactory.cpp ${IFACE}/tqwidgetintdict.cpp
${IFACE}/tqwidgetlist.cpp ${IFACE}/tqwmatrix.cpp ${IFACE}/tqxml.cpp ${IFACE}/private/tqucomextra_p.cpp
+ ${INPUTMETHOD_SOURCES}
VERSION 4.2.0
LINK ${TQT_LIBRARIES}
DESTINATION ${LIB_INSTALL_DIR}